Utils

kullanışlı
araçlar

Yardımcı Programlar

nette/utils paketinde günlük kullanım için bir dizi yararlı sınıf bulacaksınız:

Diziler Nette\Utils\Arrays
Geri Çağırma Nette\Utils\Callback
Tarih ve Saat Nette\Utils\DateTime
Dosya Sistemi Nette\Utils\FileSystem
Finder Nette\Utils\Finder
Floats Nette\Utils\Floats
Yardımcılar Nette\Utils\Helpers
HTML Elemanları Nette\Utils\Html
Görüntüler Nette\Utils\Image
JSON Nette\Utils\Json
Nesne modeli Nette\SmartObject & Nette\StaticClass
Paginator Nette\Utils\Paginator
PHP Yansıması Nette\Utils\Reflection
PHP Türleri Nette\Utils\Type
Rastgele Dizeler Nette\Utils\Random
Dizeler Nette\Utils\Strings
Doğrulayıcılar Nette\Utils\Validators

Kurulum

Composer'ı kullanarak paketi indirin ve yükleyin:

composer require nette/utils
sürüm PHP ile uyumlu
Nette Utils 4.0 PHP 8.0 – 8.2
Nette Utils 3.2 PHP 7.2 – 8.2
Nette Utils 3.0 – 3.1 PHP 7.1 – 8.0
Nette Utils 2.5 PHP 5.6 – 8.0

En son yama sürümleri için geçerlidir.

versiyon: 4.0