Migration

How to migrate to newer version of Nette.

from 2.3 to 2.4 requires PHP 5.6
from 2.2 to 2.3 requires PHP 5.4
from 2.1 to 2.2 requires PHP 5.3
from 2.0 to 2.1 requires PHP 5.3