Migrating to Version 3.2

Minimum required PHP version is 8.1.

Nette version 3.2 means that you have these packages installed in version 3.2.*:

"require": {
	"nette/application": "3.2.*",
	"nette/bootstrap": "3.2.*",
	"nette/forms": "3.2.*",
	"nette/http": "3.3.*",
	"nette/security": "3.2.*",

Warning: for other packages, install the latest version that Composer will allow! They may have different versioning. Try "*" and see what version Composer installs.


This version takes full advantage of all the features of PHP 8. So the code contains all the new typehints introduced in PHP 8, types for properties, new language features and native functions. I have tried to maintain backward compatibility as much as possible and where adding a type might break something, I have not added it yet.

Furthermore, classes have, with a few exceptions, no longer use the Nette\SmartObject trait, as its enhancements after many years have made their way into PHP itself and are no longer needed.

Finder has moved to the package nette/utils, remove it from composer.